Like all well behaved technology Desired State Configuration (DSC) requires access to WMI. Specifically it needs root/Microsoft/Windows/DesiredStateConfiguration

This is available on the Windows 2012 R2 DSC server you configure but isn’t available on older versions of Windows.

You must install Windows Management Framework 4.0  (PowerShell 4.0) on any machine that you are going to configure through DSC. Windows Server 2012 already has it installed but for Windows 2008 R2 & Windows 2012 you’ll need to download the appropriate version of WMF 4.0 and install it.

This entry was posted in PowerShell and WMI, PowerShell v4. Bookmark the permalink.

2 Responses to DSC and WMI

  1. Jen says:

    Hi, thanks for posting this information. I have a pull server set up and a Windows 2008 R2 client. The following command works for Windows 2012, but not 2008.

    Invoke-CimMethod -ComputerName servername -Namespace root/microsoft/windows/desiredstateconfiguration `
    -Class MSFT_DscLocalConfigurationManager -MethodName PerformRequiredConfigurationChecks `
    -Arguments @{Flags = [uint32]1} -Verbose

    Is there something different about Windows 2008 here?

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s